$re = '/^(?<pronoun>[A-Za-z0-9]+) is (?<adjective>[A-Za-z0-9]+)$/m';
$str = 'This is good
This this is good';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);