use strict;
my $str = '@Alice @ home asds@sadsa';
my $regex = qr/(?:^|(?<=\s))@(?!\s)/imp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";