import re
regex = re.compile(r"(?:^|(?<=\s))@(?!\s)", flags=re.IGNORECASE | re.MULTILINE)
test_str = "@Alice @ home asds@sadsa"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)