package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.)([A-\x43])[\x43-Z]$`)
var str = `CAT
COW
CBL`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}