$re = '/^(.)([A-\x43])[\x43-Z]$/m';
$str = 'CAT
COW
CBL';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);