$re = '/^(?=.*[A-Z])(?=.*\d)(?=.*[a-z])(?=.*[@%$]).+$/m';
$str = 'aasasB12@
asdas!@As';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);