re = /^(?=.*[A-Z])(?=.*\d)(?=.*[a-z])(?=.*[@%$]).+$/m
str = 'aasasB12@
asdas!@As'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end