package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)((AD)|(AG)|(EX))\d*`)
var str = `EX09551115
AD09551115
AG09551115
EA09551115
EG09551115
AE09551115
AX09551115
DG09551115
GD09551115
XE09551115
GA09551115
DA09551115
XD09551115
XG09551115
GX09551115
DX09551115`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}