re = /((AD)|(AG)|(EX))\d*/mi
str = 'EX09551115
AD09551115
AG09551115
EA09551115
EG09551115
AE09551115
AX09551115
DG09551115
GD09551115
XE09551115
GA09551115
DA09551115
XD09551115
XG09551115
GX09551115
DX09551115'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end