using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((AD)|(AG)|(EX))[0-9]{8}";
string input = @"EX09551115
AD09551115
AG09551115
EA09551115
EG09551115
AE09551115
AX09551115
DG09551115
GD09551115
XE09551115
GA09551115
DA09551115
XD09551115
XG09551115
GX09551115
DX09551115";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}