import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((AD)|(AG)|(EX))[0-9]{8}";
final String string = "EX09551115 \n"
+ "AD09551115 \n"
+ "AG09551115 \n\n"
+ "EA09551115 \n"
+ "EG09551115 \n"
+ "AE09551115 \n"
+ "AX09551115 \n"
+ "DG09551115 \n"
+ "GD09551115 \n"
+ "XE09551115 \n"
+ "GA09551115 \n"
+ "DA09551115 \n"
+ "XD09551115 \n"
+ "XG09551115 \n"
+ "GX09551115 \n"
+ "DX09551115";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}