import re
regex = re.compile(r"(?:^|\n)(\d+:\d{4}) (\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}\.\d{3}) ([A-Za-z\n]+) (.*?)(?=\n\d+:|$)", flags=re.DOTALL)
test_str = ("5376:0084 2015-08-07 13:51:29.103 Error ### Error Message ###\n"
"5376:0084 2015-08-07 13:51:35.545 Error Discarding invalid session\n"
" System.Web.Services.Protocols.SoapException: Verify Session ID failed\n"
" at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)\n"
" at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)\n"
"5376:0084 2015-08-07 13:51:36.013 Error ### Error Message ###")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")