use strict;
my $str = '---vancouver----
----vancouver----job----
----job---vancouver----';
my $regex = qr/^((?!job).)*(toronto|vancouver|calgary|halifax|winnipeg|ottawa|edmonton|regina|mississauga)(?!.*job)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}