re = /^((?!job).)*(toronto|vancouver|calgary|halifax|winnipeg|ottawa|edmonton|regina|mississauga)(?!.*job)/m
str = '---vancouver----
----vancouver----job----
----job---vancouver----'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end