package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:
[^,()]++
(?<args>
\(
(?:
[^()]++
| \g<args>
)*+
\)
)*+
)+`)
var str = `a,b,func1(a,b+c),func2(a*b,func3(a+b,c)),func4(e)+func5(f),func6(func7(g,h)+func8(i,(a)=>a+2)),g+2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}