re = /(?:
[^,()]++
(?<args>
\(
(?:
[^()]++
| \g<args>
)*+
\)
)*+
)+/x
str = 'a,b,func1(a,b+c),func2(a*b,func3(a+b,c)),func4(e)+func5(f),func6(func7(g,h)+func8(i,(a)=>a+2)),g+2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end