using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" ?\b([^: ]+ ?[^: ]+) ?: ";
string input = @"Device: ILO 5 Firmware Version : 2:33 Firmware date : 10-10-2020";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}