package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i) ?\b([^: ]+ ?[^: ]+) ?: `)
var str = `Device: ILO 5 Firmware Version : 2:33 Firmware date : 10-10-2020`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}