$re = '/(?<=_Photo)\d+(?=_)/i';
$str = 'DATE_Photo003_NAME
DATE_Photo042_NAME
DATE_Photo110_NAME
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);