re = /(?<=_Photo)\d+(?=_)/i
str = 'DATE_Photo003_NAME
DATE_Photo042_NAME
DATE_Photo110_NAME
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end