#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<a\s[\s\S]*?<\/a>|<[^>]+>|\b((?:htt|ft)ps?:\/\/[^"<\s]+)"
Local $sString = ""http://www.website.com"" & @CRLF & _
"https://www.website.com" & @CRLF & _
""ftp://www.website.com" & @CRLF & _
"ftps://www.website.com" & @CRLF & _
"" & @CRLF & _
"<u>http://www.website.com</u>" & @CRLF & _
"This is a link http://www.website.com that is not linked ftp://www.website.com" & @CRLF & _
"This is a long link http://www.website.com/index.htm?foo=bar" & @CRLF & _
"" & @CRLF & _
"<a href="http://www.website.com" target="_blank">http://website.com</a >" & @CRLF & _
"<a href="https://www.website.com">http://website.com</a>" & @CRLF & _
"<a href="http://www.website.com"><u>http://www.website.com</u></a>" & @CRLF & _
"<a href="ftp://www.website.com">ftp://www.website.com</a>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<img src="http://www.website.com" target="_blank"/>" & @CRLF & _
"" & @CRLF & _
"<a href="http://www.website.com" target="_blank">" & @CRLF & _
"http://website.com" & @CRLF & _
"</a>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<a href="http://www.website.com">" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://www.website.com" & @CRLF & _
"" & @CRLF & _
"http://www.website.com " & @CRLF & _
" " & @CRLF & _
"</a>" & @CRLF & _
"" & @CRLF & _
"Lorem ipsum Test dolor sit amet, consetetur sadhttp://url.comipscing elitr, sed diam <a href="http://Test.com/url">Test</a> eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam http://url.com et justo..." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<a href="http://www.website.com">" & @CRLF & _
"" & @CRLF & _
"http://www.website.com" & @CRLF & _
"<img src="http://www.website.com" target="_blank"/>" & @CRLF & _
"http://www.website.com" & @CRLF & _
"</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")