import Foundation
let pattern = #"<a\s[\s\S]*?<\/a>|<[^>]+>|\b((?:htt|ft)ps?:\/\/[^"<\s]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
"http://www.website.com"
https://www.website.com
"ftp://www.website.com
ftps://www.website.com
<u>http://www.website.com</u>
This is a link http://www.website.com that is not linked ftp://www.website.com
This is a long link http://www.website.com/index.htm?foo=bar
<a href="http://www.website.com" target="_blank">http://website.com</a >
<a href="https://www.website.com">http://website.com</a>
<a href="http://www.website.com"><u>http://www.website.com</u></a>
<a href="ftp://www.website.com">ftp://www.website.com</a>
<img src="http://www.website.com" target="_blank"/>
<a href="http://www.website.com" target="_blank">
http://website.com
</a>
<a href="http://www.website.com">
http://www.website.com
http://www.website.com
</a>
Lorem ipsum Test dolor sit amet, consetetur sadhttp://url.comipscing elitr, sed diam <a href="http://Test.com/url">Test</a> eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam http://url.com et justo...
<a href="http://www.website.com">
http://www.website.com
<img src="http://www.website.com" target="_blank"/>
http://www.website.com
</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)