import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bin stock\\b|(?:\\s+|^)((?:(?!\\b(?:notify|not in stock|in stock)\\b).)+\\b(?:notify|not in stock)\\b)";
final String string = "item1 120usd not in stock item2 150usd in stock item3 100usd notify item4 12usd in stock item5 25usd not in stock item6 250usd notify item7 50usd in stock item8 30sud in stock item9 5usd notify item10 5usd notify";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}