const regex = /\bin stock\b|(?:\s+|^)((?:(?!\b(?:notify|not in stock|in stock)\b).)+\b(?:notify|not in stock)\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bin stock\\b|(?:\\s+|^)((?:(?!\\b(?:notify|not in stock|in stock)\\b).)+\\b(?:notify|not in stock)\\b)', 'gm')
const str = `item1 120usd not in stock item2 150usd in stock item3 100usd notify item4 12usd in stock item5 25usd not in stock item6 250usd notify item7 50usd in stock item8 30sud in stock item9 5usd notify item10 5usd notify`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}