package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^hello$`)
var str = `hello
hellos
hello3
1hello
shello
$hello#
hello#`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}