$re = '/^hello$/m';
$str = 'hello
hellos
hello3
1hello
shello
$hello#
hello#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);