import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\.{2})(?!\\.)[a-z0-9_.'-]*[a-z0-9_'-]@(?!_)(?:[a-z0-9_'-]+\\.)+[a-z0-9_'-]{2,}$";
final String string = "ya.ll.t.j@gg.cc\n"
+ "ya..l.f@dd.cc\n"
+ "y.s.sss...@kk.dd\n\n"
+ "allowed: uppercase and lowercase English letters, digits 0 to 9\n\n"
+ "allowed: \"_\", \"-\", “.”, “@” and \"'\";\n\n"
+ "3.a. Character \".\" is allowed to be provided if it is not the first or last character\n"
+ "a.b@def.com\n"
+ ".b@def.com\n"
+ "a.@def.com\n\n"
+ "3.b. \".\" does not appear two or more times consecutively\n"
+ "a..b@def.com\n"
+ "a.b@def..com\n\n"
+ "3.c. \".\" must appear at least one time in domain name\n"
+ "a.b@defcom\n\n"
+ "should not contain “.@” or “@.”\n"
+ "a.b@.def.com\n"
+ "a.b.@def.com\n\n"
+ "In the domain name, the string length, after last “.” , should have at least 2 characters\n"
+ "a.b@def.c\n\n"
+ "Leading \"_\" is not allowed in the domain name\n"
+ "a.b@_def.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}