const regex = /^(?!.*\.{2})(?!\.)[a-z0-9_.'-]*[a-z0-9_'-]@(?!_)(?:[a-z0-9_'-]+\.)+[a-z0-9_'-]{2,}$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\.{2})(?!\\.)[a-z0-9_.\'-]*[a-z0-9_\'-]@(?!_)(?:[a-z0-9_\'-]+\\.)+[a-z0-9_\'-]{2,}$', 'gmi')
const str = `ya.ll.t.j@gg.cc
ya..l.f@dd.cc
y.s.sss...@kk.dd
allowed: uppercase and lowercase English letters, digits 0 to 9
allowed: "_", "-", “.”, “@” and "'";
3.a. Character "." is allowed to be provided if it is not the first or last character
a.b@def.com
.b@def.com
a.@def.com
3.b. "." does not appear two or more times consecutively
a..b@def.com
a.b@def..com
3.c. "." must appear at least one time in domain name
a.b@defcom
should not contain “.@” or “@.”
a.b@.def.com
a.b.@def.com
In the domain name, the string length, after last “.” , should have at least 2 characters
a.b@def.c
Leading "_" is not allowed in the domain name
a.b@_def.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}