$re = '/^(.*?)%?(.{2})$/m';
$str = '123456%89
12345689';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);