import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.GPS\\.\\s+\\K\\d+";
final String string = "Wed Aug 27 20:24:53.536 IST\n\n"
+ " address ref clock st when poll reach delay offset disp\n"
+ "*~172.16.18.163 .GPS. 1 657 1024 377 13.99 1.801 19.630\n"
+ " ~127.127.1.1 .LOCL. 3 15 64 377 0.00 0.000 1.920\n"
+ " * sys_peer, # selected, + candidate, - outlayer, x falseticker, ~ configured";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}