import re
regex = re.compile(r"\.GPS\.\s+\K\d+", flags=re.DOTALL)
test_str = ("Wed Aug 27 20:24:53.536 IST\n\n"
" address ref clock st when poll reach delay offset disp\n"
"*~172.16.18.163 .GPS. 1 657 1024 377 13.99 1.801 19.630\n"
" ~127.127.1.1 .LOCL. 3 15 64 377 0.00 0.000 1.920\n"
" * sys_peer, # selected, + candidate, - outlayer, x falseticker, ~ configured")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")