package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?i)(((ldap|ldap):\/\/){0,1})((?i)(ou|cn)=(([a-zA-Z0-9]|[-]|[_])){1,63},)+((?i)(dc=)(([a-zA-Z0-9]|[-]|[_])){1,63},){1,2}(?i)(dc=)(([a-zA-Z0-9]){2,63})$`)
var str = `CN=users,DC=example,DC=com
OU=mailgroups,OU=People,OU=organisation,DC=example,DC=at
LDAP://OU=mailgroups,OU=People,OU=organisation,DC=example,DC=at`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}