re = /^(?i)(((ldap|ldap):\/\/){0,1})((?i)(ou|cn)=(([a-zA-Z0-9]|[-]|[_])){1,63},)+((?i)(dc=)(([a-zA-Z0-9]|[-]|[_])){1,63},){1,2}(?i)(dc=)(([a-zA-Z0-9]){2,63})$/m
str = 'CN=users,DC=example,DC=com
OU=mailgroups,OU=People,OU=organisation,DC=example,DC=at
LDAP://OU=mailgroups,OU=People,OU=organisation,DC=example,DC=at'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end