using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<img[^>]*?photobucket.*?>)";
string input = @"<img src=""/photobucket/img21.png"">
Do Not Want:
<img src=""/imgs/test.jpg"">
<img src=""/imgs/thiswillgetpulledtoo.jpg""><p>We like photobucket</p>
<img src=""/photobucket/img21.png"">";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}