const regex = /(<img[^>]*?photobucket.*?>)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<img[^>]*?photobucket.*?>)', 'gmi')
const str = `<img src="/photobucket/img21.png">
Do Not Want:
<img src="/imgs/test.jpg">
<img src="/imgs/thiswillgetpulledtoo.jpg"><p>We like photobucket</p>
<img src="/photobucket/img21.png">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}