package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d\ *(?:\(\d+\))?[- \d]+$`)
var str = `yes
1 (555) 555-5555
5555555555
1 555-555-5555
555-555-5555
no
1 555)555-5555
(6505552368)
10 (757) 622-7382
555)-555-5555`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}