use strict;
my $str = 'yes
1 (555) 555-5555
5555555555
1 555-555-5555
555-555-5555
no
1 555)555-5555
(6505552368)
10 (757) 622-7382
555)-555-5555';
my $regex = qr~^\d\ *(?:\(\d+\))?[- \d]+$~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}