import re
regex = re.compile(r"((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)", flags=re.MULTILINE)
test_str = ("172.16.11.151\n"
"172.16.11.151\n"
"172.16.11.151.23\n"
"1.2.4.6\n"
"This is a IPV4 address 24.133.1.1.\n"
"If there is no space before IPV4 address0.0.0.0aaa.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")