re = /((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)/m
str = '172.16.11.151
172.16.11.151
172.16.11.151.23
1.2.4.6
This is a IPV4 address 24.133.1.1.
If there is no space before IPV4 address0.0.0.0aaa.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end