import re
regex = re.compile(r"^(.+)\.html(.*)$")
test_str = "https://example.com/about.html?pageback=video&jdjahdjahd"
subst = "$1$2"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)