// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(.+)\.html(.*)$").unwrap();
let string = "https://example.com/about.html?pageback=video&jdjahdjahd";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}