const regex = /\S{3}\.(\S+)\.com|\S{3}\.(\S+)\.es/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S{3}\\.(\\S+)\\.com|\\S{3}\\.(\\S+)\\.es', 'gm')
const str = `/amp.farodevigo.com/gran-vigo/2017/08/30/concello-habilitara-tercera-playa-perros/1741197.html,8,0.00,100.00%,0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}