re = /\S{3}\.(\S+)\.com|\S{3}\.(\S+)\.es/m
str = '/amp.farodevigo.com/gran-vigo/2017/08/30/concello-habilitara-tercera-playa-perros/1741197.html,8,0.00,100.00%,0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end