const regex = new RegExp('^(?P<opcode>[a-zA-Z]+)(?P<byte_mode>\\.[BbWw])?(?:\\s+)(?P<operand_src>[A-Za-z0-9@\\(\\)]+)(?:(?:,\\s*)|(?:\\s+))(?P<operand_dst>[A-Za-z0-9@\\(\\)]+)', 'gm')
const str = `add 23(PC), 6(R11)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}