use strict;
my $str = 'add 23(PC), 6(R11)';
my $regex = qr/^(?P<opcode>[a-zA-Z]+)(?P<byte_mode>\.[BbWw])?(?:\s+)(?P<operand_src>[A-Za-z0-9@\(\)]+)(?:(?:,\s*)|(?:\s+))(?P<operand_dst>[A-Za-z0-9@\(\)]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}