import re
regex = re.compile(r"\(?\s*\d?\s*-?\d{3}\s*[)-]?\s*\d{3}\s*-?\s*\d{4}\)?", flags=re.MULTILINE)
test_str = "nums here (111)123-4567 or (1-800-111-2222)(123)1234567 or 321-123-4567 or ( 112)123-4567 or (113 )123-4567"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")