re = /\(?\s*\d?\s*-?\d{3}\s*[)-]?\s*\d{3}\s*-?\s*\d{4}\)?/m
str = 'nums here (111)123-4567 or (1-800-111-2222)(123)1234567 or 321-123-4567 or ( 112)123-4567 or (113 )123-4567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end