re = /(?<=\[)[^\[\]]+(?=\])(?#This matches anything DIRECTLY between two square brackets)/m
str = 'abcd[bddb]xyyx
abba[mnop]qrst
abba[mnop[ibbi]abba]qrts
'
subst = 'gaylmao'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result