import Foundation
let pattern = ##"(?<=\[)[^\[\]]+(?=\])(?#This matches anything DIRECTLY between two square brackets)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abcd[bddb]xyyx
abba[mnop]qrst
abba[mnop[ibbi]abba]qrts
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"gaylmao"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)