#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\S+:(?=.*$)"
Local $sString = "El Chico Mexican Restaurant" & @CRLF & _
"(555-555-5555)" & @CRLF & _
"Server: Mike" & @CRLF & _
"Drk: Water APT: Chip Salse Entrée: Grando Chicken Dessert: Pie"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")